abacom-online.de

Das offizielle Elektronik-Software Forum
Aktuelle Zeit: Donnerstag 21. September 2017, 02:28

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Freitag 14. April 2017, 09:40 
Offline

Registriert: Donnerstag 16. April 2015, 12:17
Beiträge: 23
Dear All,
I truly apologize for asking help on what would be easy things for most of you here, however I have some great difficulties to get the PID to work correctly.

In the plotter the trace colors represent

Red = FB signal
Blue = Set point(X+)
Orange = Controller output,

I have set the limit properties of the Controller components as shown in the attached screen print.(in a separate post as the forum allows only 3 attachments per post)
In my understanding of reading the plot is

(1)As the error goes bigger Error = (Set-point - FB signal) the controller output increases ,correctly so as the output in my understanding is trying to correct the error.
(2)As the error is not reduced the integrator is increasing the controller output until the max limit is reached ,which it is doing as the output reached the 117 max limit in the plot.
(the error was deliberately not reduced to show this and indicate my problem) .
(3) With the control output at maximum and the error is staring to correct (going to zero),the controller output stay at maximum until the error reached the zero (minimum setting ) then the output fell from maximum to zero.

This is my issue once saturation is reached the control output does not reduce gradually back to minimum value.it hangs on maximum until the error is zero(0) then control output drop to zero.

In my lack of knowledge it seems to me the integrator does not stop when maximum output is reached and when the error is deceasing the high integrator value keeps the output high.

Any advise on how to correct this issue would be be greatly appreciated .

I have tried the following by resetting the integrator by pulling the RST pin low when the output has reached the maximum.
This did not give good results as the controller output drop to a lower value, then the RST pin goes , integration is started , output goes to max again and RST is pulled low again.
This process just keeps going in this way .

As shown in the 3rd screen print.
In the red marked area is a reset function when the error is small , I stop the integration.
In blue a function that stop the integration when max is reached and was the result of trying to solve the issue I described above.


Dateianhänge:
1.JPG
1.JPG [ 66.43 KiB | 763-mal betrachtet ]
3.JPG
3.JPG [ 35.02 KiB | 757-mal betrachtet ]
4.JPG
4.JPG [ 38.23 KiB | 758-mal betrachtet ]


Zuletzt geändert von QMESAR am Freitag 14. April 2017, 09:54, insgesamt 1-mal geändert.
Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Freitag 14. April 2017, 09:48 
Offline

Registriert: Donnerstag 16. April 2015, 12:17
Beiträge: 23
The screen print of the PID settings


Dateianhänge:
2.JPG
2.JPG [ 28.92 KiB | 755-mal betrachtet ]
Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Freitag 14. April 2017, 22:05 
Offline

Registriert: Mittwoch 4. November 2009, 18:32
Beiträge: 457
You are writing a lot of things, but nothing of importance, pertaining the problems you seem to have.
    What are you intending to control with PID? (the application itself)
    State as many details as possible.
    What sort of HW (hardware) are you employing?

Below a basic drawing of a minimalistic Cirquit:


Dateianhänge:
PID-Controller.png
PID-Controller.png [ 97.84 KiB | 730-mal betrachtet ]

_________________
++++++
Gruss/regards IKT
Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Samstag 15. April 2017, 14:19 
Offline

Registriert: Donnerstag 16. April 2015, 12:17
Beiträge: 23
Thank you for your reply however when I have to write all you are asking then I will again get attacked about I write to much and my writing style as it seems the forum is more related to grammar learning as the technical aspects of the PL SW


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Samstag 15. April 2017, 19:16 
Offline

Registriert: Mittwoch 4. November 2009, 18:32
Beiträge: 457
Well, -- you're the one, seeking help ...
Unless we (others included), understand the exact nature of the problem, you seem to have,
there is simply no chance, to give/receive a decent answer. (No mind readers here, sorry!)

_________________
++++++
Gruss/regards IKT


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Sonntag 16. April 2017, 06:47 
Offline

Registriert: Donnerstag 16. April 2015, 12:17
Beiträge: 23
IKT,
Thank you for your reply ,
The PID is part of a complex control system on a Test/development rig for Turbo chargers,in our R&D test Laboratory in Germany .

I will take the time to cutout the relevant signals and HW to the PID problem we see with PL only. I must admit the same hardware is running on an older Test rig with LABVIEW 7 and that has no such issue.
The decision to use PL was purely based on a cost and after trying it on some smaller test projects which worked fine the team thought it might be a solution in future for many test application.As PL is relative easy to work with but with this PID stuff not responding as a person should think, it starts to look like it not an option as the support for PL is non existing maybe that is the reason it is so cheap .
As the developers from PL hardly answer any problems in the Forum nor at their email it looks like buy use it or loose it and when they do, they answer in away that give the impression they are very arrogant. My apologies to them but if they look closer they would realize that this is how it is their answer make you feel like hu what an idiot question you asked

I will give this a last try if it yields no results we will throw PL and spend the 9000 Euro to upgrade our LABVIEW licenses and consider the time and money lost with ABBACOM as school fees
with the old saying coming true ,You get what you pay for PL cost nothing and you also get nothing

Just in general I am not a control specialist however I am a HW developer for many years and not such an idiot as people in this forum has tried to tell in their diplomatic ways. After all in my opinion the purpose of the forum is to support the PL product ,and the main contributor should be the product supplier.As they have no official support at their office when you ask support at them directly, they refer you to the Forum!, in the forum you get scolded by other users ,it is clear normal forum users has no obligation to support any questions in the forum, however the supplier has some degree of responsibility to support their product ,or they must clearly state this in their sales that you purchase SW with out any support not saying support in our Forum as they do
I am afraid to ask anything in the forum as each and every post I get scolded about how I am writing and how stupid I ask questions ,in my opinion most people around here English is their second or third language may be the German perfection should be a little more tolerant :)
In my case English is my third language,I will be very happy if I could ask my questions in Afrikaans or Russian which is my first and second language and then I could scold you people around here for the ways you present yourselves .

Kind Regards

Happy easter and please find all the eggs :D


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Sonntag 16. April 2017, 14:13 
Offline

Registriert: Mittwoch 4. November 2009, 18:32
Beiträge: 457
QMESAR hat geschrieben:
In my case English is my third language,I will be very happy if I could ask my questions in Afrikaans or Russian which is my first and second language
Just to get the "Language Issue" out of the System (Date/Time ordered):
    1) Swiss-German (native)
    2) German (Business: second, in order of importance)
    3) English (Business: first, in order of importance)
    4) Afrikaans (only spoken/never written and also, never schooled)
No Russian here, I'm afraid. Looks like we're stuck with English ...

I'm more into PID than, into Easter Eggs :lol:. I'll send you a IM ...

_________________
++++++
Gruss/regards IKT


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Montag 17. April 2017, 06:26 
Offline

Registriert: Donnerstag 16. April 2015, 12:17
Beiträge: 23
IKT hat geschrieben:
I'm afraid. Looks like we're stuck with English ...


:D Sure looks that way.
I have send you an mail.
Have good one.

Kind Regards


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Problems working with the Integrator of the PID Controller
BeitragVerfasst: Dienstag 18. April 2017, 10:19 
Offline

Registriert: Donnerstag 16. April 2015, 12:17
Beiträge: 23
Thank you very much IKT for his help that resolved the issue :D

Many Thanks to you again IKT


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Deutsche Übersetzung durch phpBB.de