Parent-Child Verbindungen sind weg

Wir bemühen uns Ihre Fragestellung zu beantworten.
Antworten
Schreddl
Beiträge: 10
Registriert: Dienstag 29. November 2016, 15:43

Parent-Child Verbindungen sind weg

Beitrag von Schreddl » Freitag 12. Mai 2017, 11:33

Hallo.
Hab schon wieder ein Problem.
Ich habe (nach der Fehlerhaften Datei-Aktion) das Internet Update durchgeführt.
Jetzt bin ich dabei ein Projekt mit neuen Formblättern auszustatten.
101 neue Formblätter, nur weil ein Logo noch drauf muss! :(

Das Problem ist, das ziemlich viele Parent-Child Verbindungen einfach weg sind!
Es steht dann immer <Parent_id> und <Parent_value> vor dem Bauteil.

Liegt das mit dem Internet Update oder mit dem neuen Formblatt zusammen???

Gruß Daniel

abacom
Site Admin
Beiträge: 3225
Registriert: Dienstag 23. September 2008, 10:54
Kontaktdaten:

Re: Parent-Child Verbindungen sind weg

Beitrag von abacom » Montag 15. Mai 2017, 09:10

Das kann nicht an dem Update liegen.
Wenn ein Child nur <Parent_ID> und <Parent_Value> anzeigt, dann ist sein Parent möglicherweise gelöscht worden.
Haben Sie evt. versehentlich Bauteile auf der Formblatt-Ebene platziert? Diese wären dann beim Laden eines neuen Formblattes nicht mehr vorhanden.
ABACOM support

Schreddl
Beiträge: 10
Registriert: Dienstag 29. November 2016, 15:43

Re: Parent-Child Verbindungen sind weg

Beitrag von Schreddl » Montag 15. Mai 2017, 12:11

Hallo.
Hab gerade gemerkt das es was mit den Formblättern zu tun hat.
Die Aktuelle Seitenzahl ist im Formblat als Bauteil definiert.
Damit ich "Verweispfeile" Seitenabhängig gestalten kann.

Schade das es damit zusammenhängt.
Dachte, die Seite ist doch immer noch die selbe; das geht.

*hmmmtz* Auf 101 Seiten alle Parent-Child Verbindungen neu machen.

Kann ich eigentlich die Parent ID selbst vergeben?
Oder geht das nur über "Rechts-Klick" - "Setze Parent"?
Weil wenn ich das mache muss ich auch immer wieder in den Eigenschaften den Wert neu eingeben.

Hoffe das ist verständlich was ich meine.

Gruß Daniel

abacom
Site Admin
Beiträge: 3225
Registriert: Dienstag 23. September 2008, 10:54
Kontaktdaten:

Re: Parent-Child Verbindungen sind weg

Beitrag von abacom » Montag 15. Mai 2017, 12:29

Ein Parent kann nur über "Setze Parent..." zugewiesen werden.
Sie können ein "fertiges" Child aber auch kopieren, und dann mehrmals auf verschiedenen Seiten einfügen. Die Parent-Verknüpfung bleibt auch beim eingefügten Bauteil erhalten.
ABACOM support

Schreddl
Beiträge: 10
Registriert: Dienstag 29. November 2016, 15:43

Re: Parent-Child Verbindungen sind weg

Beitrag von Schreddl » Montag 15. Mai 2017, 13:04

Schade.
Das bringt mir leider nichts.
Vllt wär das was für die sPlan 8.0.
So wie auch die Möglichkeit auf einen Schlag alle Formblätter im ganzen Projekt "auszutauschen".

Trotzdem, egal wie:
Tolle Software, super Preis-Leistungs Verhältnis und ein hilfreicher, schneller Support!
Danke!

Gruß Daniel

Antworten

Zurück zu „SPLAN SOFTWARE Support“