Velleman: K8055 / P8055-1 2003

Antworten
Prüfi
Beiträge: 36
Registriert: Montag 30. November 2009, 18:58

Velleman: K8055 / P8055-1 2003

Beitrag von Prüfi » Mittwoch 3. März 2010, 23:52

Ich hab die mal geschenkt gekriegt, heute mal zusammen gelötet.

Aber auf USB2 Computer scheint die total nicht zu funktionieren.

GeräteManager: Code10 (Gerät konnte nicht gestartet werden)

Versuche: Bios auf USB1.0 geschaltet, win2k installiert, andere computer (auch usb2.0)


In linux ist es eigentlich definitiv:

3.
[ 105.150026] usb 4-3: new low speed USB device using ohci_hcd and address 2
4.
[ 105.369344] usb 4-3: device descriptor read/all, error -62
5.
[ 105.552007] usb 4-3: new low speed USB device using ohci_hcd and address 3
6.
[ 105.773403] usb 4-3: unable to read config index 0 descriptor/start: -62
7.
[ 105.773408] usb 4-3: chopping to 0 config(s)
8.
[ 105.778546] usb 4-3: string descriptor 0 read error: -62
9.
[ 105.778664] usb 4-3: no configuration chosen from 0 choices
10.
[ 105.778701] hub 4-0:1.0: port 3 disabled by hub (EMI?), re-enabling...
11.
[ 105.778704] usb 4-3: USB disconnect, address 3
12.
[ 106.121287] usb 4-3: new low speed USB device using ohci_hcd and address 4
13.
[ 106.340828] usb 4-3: device descriptor read/all, error -62
14.
[ 106.531283] usb 4-3: new low speed USB device using ohci_hcd and address 5
15.
[ 106.751051] usb 4-3: device descriptor read/all, error -62
16.
[ 106.941298] usb 4-3: new low speed USB device using ohci_hcd and address 6
17.
[ 106.983151] usb 4-3: device descriptor read/all, error -62
18.
[ 107.180056] usb 4-3: new low speed USB device using ohci_hcd and address 7
19.
[ 107.221276] usb 4-3: device descriptor read/all, error -62
20.
[ 107.231307] hub 4-0:1.0: unable to enumerate USB device on port 3




Bei 50maligen Aus/Einstecken des USB Kabel kriegt man dann mal zufällig die Karte ans laufen USB technisch. Jedoch auch nur so für 1 bis 5min.


Ich glaub das der PIC nicht kompatible ist mit USB2 Chips der heutigen Generation und dessen protokoll.

Naja, pech gehabt.

Alle I/O Test (Analog wie Digital erfolgreich) konnte ich machen, wenn ich sie mal online bekamm.
:cry:


Das einzige wo ich sähe den PIC neu zu flashen, wenn der Hersteller was hätte, leider nicht. Dammich. So ein USB Flash wird es nicht geben :(

Und dann ist der PIC mit 6Mhz getaktet, würde man doch meinen, man würde USB2 hinkriegen, oder mindestens im Protokoll ne korrektur, aber da ist nichts bei Velleman Download, scheinbar unbekannt das Problem. Oder man intressiert sich nicht für das.

abacom
Site Admin
Beiträge: 3372
Registriert: Dienstag 23. September 2008, 10:54
Kontaktdaten:

Re: K8055 P8055-1 Velleman 2003

Beitrag von abacom » Donnerstag 4. März 2010, 08:51

Ich glaube nicht, dass das ein grundsätzliches Problem des Gerätes ist. Vielleicht doch ein Bestückungsfehler? ...oder Treiberproblem? oder...?
ABACOM support

tmm
Beiträge: 357
Registriert: Montag 23. Februar 2009, 06:38

Re: K8055 P8055-1 Velleman 2003

Beitrag von tmm » Donnerstag 4. März 2010, 16:25

Hallo,

ich habe von dieser Karte hier bei uns ca. 10 Stück im Einsatz, die laufen ohne rumzuzicken (allerdings kaufe ich die fertig bestückte Version) auch in Verbindung mit USB/RS232 Wandler und sonsigen USB-Geräten (ich denke da auch an einen Bestückungsfehler).

Gruß MM

Prüfi
Beiträge: 36
Registriert: Montag 30. November 2009, 18:58

Re: K8055 P8055-1 Velleman 2003

Beitrag von Prüfi » Donnerstag 4. März 2010, 17:23

Ich hab einen Compter mit USB2.0 gefunden, wo sie anstandslos läuft. Ich hatte mal ein Canon Pixma PM250 oder so bei meiner Schwester. Der wollte nicht mit VIA USB chips auf Speed2. Was vorallem beim Scannen ekelhaft war.

Die Lösung ist vielleicht eine PCI-USB Karte, aber beim neuen Laptop geht das natürlich nicht. Vielleicht ein USB-HUB, aber der ist gerade auf "Tauchfahrt" :)

Treiber: Der USB-HID Treiber von Microsoft wird verwendet, und der ist aus 2001 und kommt eigentlich bei allen Eingabengeräte standardmässig zum Einsatz. Es gibt keinen andern. WinXP

Im Anhang nen kleines Prüfprogi für die Karte. (hab noch LED in die Visualisierung)


Frage:
Bei PWM1+2 kann man doch mit 50Volt gegen GND rein bei der Karte oder? Also ok, besser nur so Standards wie 1Volt oder 10Volt und möglichst nur 5mA. Hat ja keine Kühlkörper dabei für T1 und T2 (BC337)

Frage:
Der RS232 Converter, wie behandelt man das dann mit Profilab?

Frage:
DAC1+2 bringen aber nur 4.67Volt bei mir. Liegt wohl am IC1, also der Transistor Verlust. Oder stimmt das bei euch auf 5Volt? Also die Wiederstände alles gecheckt. Stimmt.

Ja ok, ich würde es auch bestückt kaufen. :) Aber ich bin kein Laie, ich hab schon Platinen selber geplant, gebaut.


Fazit USB: Also wenn die USB Chips verbauen und nicht neu bennen wie USB3 oder so, kann man wirklich nichts machen. Irgendwas ist bei den neuern PC's hier anderst, dass die nicht da tut. Sorry (Auf win7 auch das gleiche "Kann nicht gestartet werden") :cry:


Sagen wir es so.. doof dass sich Velleman an konzeptionelllose hersteller anpassen muss ;)
Dateianhänge
K8055.prj
(21.69 KiB) 314-mal heruntergeladen

tmm
Beiträge: 357
Registriert: Montag 23. Februar 2009, 06:38

Re: K8055 P8055-1 Velleman 2003

Beitrag von tmm » Freitag 5. März 2010, 11:43

Hallo,

ich versuch mal deine Fragen zu beantworten:
- Frage:
- Bei PWM1+2 kann man doch mit 50Volt gegen GND rein bei der Karte oder? Also ok, besser nur so Standards wie 1Volt oder 10Volt und
- möglichst nur 5mA. Hat ja keine Kühlkörper dabei für T1 und T2 (BC337)

da musst du mal im Datenblatt nachsehen.

- Frage:
- Der RS232 Converter, wie behandelt man das dann mit Profilab?

Ich meine einen USB-RS232 Adapter - was soll man da wie behandeln ?
Hier bei uns verwende ich ein System mit 4*USB/RS232 Adapter, einer USB Pumpensteuerung und eben dem K8055 und das läuft wochenlang ohne Störung.

- Frage:
- DAC1+2 bringen aber nur 4.67Volt bei mir. Liegt wohl am IC1, also der Transistor Verlust. Oder stimmt das bei euch auf 5Volt? Also die
- Wiederstände alles gecheckt. Stimmt.

Hab ich eben mal nachgemessen:

bei 5,0 am Eingang habe ich 4,660 Volt
bei 2,5 am Eingang habe ich 2,321 Volt

- Ja ok, ich würde es auch bestückt kaufen. Aber ich bin kein Laie, ich hab schon Platinen selber geplant, gebaut.

Ich bin auch kein Laie, bin aber mittlerweile zu faul zum selbst Löten (ich muß auch immer die Brille absetzen beim Löten; das nervt)

Gruß MM

Prüfi
Beiträge: 36
Registriert: Montag 30. November 2009, 18:58

Re: K8055 P8055-1 Velleman 2003

Beitrag von Prüfi » Freitag 5. März 2010, 23:17

Hallo,

vielen Dank tmm, DAC1+2 sind also ok.

PWM1+2 sind wirklich für externe Versorgung, kann man aber eigentlich als Stromregler bezeichnen und etwas Erfahrung wie man damit umgeht. Sonst sind T1 und T2 ganz schnell kaputt, man kann aber auch einen Spannungsreglung bauen dadraus ;)

tmm, aber sorry ich hab dein 4*USB/RS232 immernoch nicht verstanden. Das ist doch ne USB Karte.

USB->RS232-<-->RS232<-USB ??

Sorry


Im Profilab Demo von der Karte wird geschrieben, nur eine Karte pro Projekt, kannst Du damit mehrere Karten gleichzeitig betreiben dieses Typs?



Für PWM1+2 hab ich Ubuntu 9.1 mit KTechLab mal den Anschluss für Industrielles Norm 24Volt und 0...20mA nachgebiltet. Ist im Anhang.

Mit LT Spice kann man das natürlich auch nachbauen/simulieren.

Dabei ist in der linken Hälfte das Velleman mit Transitor und Schutzdiode 75V, und in der rechten Hälfte der Anschluss von extern.


Das KTechLab File vom Screenshot ist hier: http://aokneufi.dyndns.org/~chris/tmp/B ... +2.circuit (ist aber Ubuntu, nicht für Windows)
Dateianhänge
Bildschirmfoto-5.png
Bildschirmfoto-5.png (176.86 KiB) 6682 mal betrachtet

tmm
Beiträge: 357
Registriert: Montag 23. Februar 2009, 06:38

Re: K8055 P8055-1 Velleman 2003

Beitrag von tmm » Samstag 6. März 2010, 09:38

Hi,

USB->RS232 (COMx)-<-->Multimeter mit seriellem Anschluß
USB->RS232 (COMx)-<-->Drucker mit seriellem Anschluß

so einen UCB/RS232 (oder auch COMx) Adapter findest du z.b. bei RS-online

http://de.rs-online.com/web/search/sear ... 124#header

Ich habe 2*K8055 (Adresse 0 und 1) an PL4.0 angeschlossen (softwareseitig Adresse 0 und 1 eingestellt) --> geht nicht - es wird bei mir nur die Karte mit der höheren Adresse angesprochen.

Wenn das mit dem USB/RS232 noch unklar ist, frag einfach nochmal.

Gruß MM

regler16
Beiträge: 26
Registriert: Freitag 26. April 2013, 20:26

Re: K8055 P8055-1 Velleman 2003

Beitrag von regler16 » Donnerstag 2. Mai 2013, 20:39

Hat jemand von Euch von der neuesten Version K8055N (=VM110N) mehrere Karten gleichzeitig am Laufen? XP / WIN7 ? Habe im Forum von Problemen (P8055) gelesen, daß hier nur eine Karte richtig läuft. Ich selbst habe eine P8055-1 die auf WIN 7 gut läuft (Kurzzeitbetrieb für div. Versuche).

Antworten

Zurück zu „Geräte: Velleman“