komisches Symptom bei Setlist

Antworten
Thommi77
Beiträge: 27
Registriert: Sonntag 11. Dezember 2016, 13:11

komisches Symptom bei Setlist

Beitrag von Thommi77 » Freitag 1. Dezember 2017, 17:57

Hallo zusammen,

folgendes ist mir bei der Setlist aufgefallen, was sich auch bei der mitinstallierten Setlist.prj nachvollziehen lässt.

Solange man den Fokus in der Setlist lässt wird auch schön das ausgewählte Set im Display ausgegeben.
Klickt man jedoch neben der Liste auf die Frontplatte so wird leider die Anzeige gelöscht. Das ist ärgerlich da nun der Bediener nicht mehr sieht welches Set als letztes gewählt wurde und demnach aktiv ist.

Der Index des Bausteines sendet dann eine -1. Ich hab schon versucht mit Sample and Hold in diesem Falle die Anzeige stehen zu lassen, hatte aber keinen Erfolg.

Hat von euch einer eine Idee ?

Danke und Gruß
Thommi77

IKT
Beiträge: 518
Registriert: Mittwoch 4. November 2009, 18:32

Re: komisches Symptom bei Setlist

Beitrag von IKT » Samstag 2. Dezember 2017, 14:03

setlist_$delay.png
Neue Schaltung:
setlist_$delay.png (22.12 KiB) 1069 mal betrachtet
Thommi77 hat geschrieben:Der Index des Bausteines sendet dann eine -1. Ich hab schon versucht mit Sample and Hold in diesem Falle die Anzeige stehen zu lassen, hatte aber keinen Erfolg. Hat von euch einer eine Idee ?
S&H ist für 'analog', $Hold für 'string'.

$Hold: ist schon der richtige Ansatz, was jedoch fehlt ist (PL-E 4.0), eine String-Verzögerung ($Delay). Dafür habe ich eine DLL geschrieben, damit und einem Trigger, funktionierts dann auch (Trigger an i, eingestellt: -0.5, mit $Hold's /Hld verdrahtet).
Die DLL zwischen den beiden $ (Ausgang resp. Eingang).

Die DLL befindet sich hier, im Forum:
$Delay (DLL)
Achtung: NICHT für kommerzielle Nutzung!
++++++
Gruss/regards IKT

Thommi77
Beiträge: 27
Registriert: Sonntag 11. Dezember 2016, 13:11

Re: komisches Symptom bei Setlist

Beitrag von Thommi77 » Mittwoch 13. Dezember 2017, 11:51

Hallo IKT,

Vielen dank für den Vorschlag.
Ich hatte es zwischenzeitlich so gelöst (siehe Bild).
Funktioniert einwandfrei.
Ein Problem können allerdings alle Vorschläge nicht lösen. Befindet sich keine *.est Datei im Ordner und versucht man die Setliste per Hotkey zu aktualisieren (z.B. Reset) dann stürzt PL mit der Mitteilung "Listenindex -1" ab. Sowohl das Hauptprogramm als auch ein Compilat.

Gruß
Thommi
Dateianhänge
Setlist_Vorschlag.PNG
Setlist_Vorschlag.PNG (10.04 KiB) 946 mal betrachtet

IKT
Beiträge: 518
Registriert: Mittwoch 4. November 2009, 18:32

Re: komisches Symptom bei Setlist

Beitrag von IKT » Mittwoch 13. Dezember 2017, 12:35

Thommi77 hat geschrieben:Ich hatte es zwischenzeitlich so gelöst (siehe Bild). Funktioniert einwandfrei.
Die DLL-Lösung, hat den Vorteil, dass sie auch funktioniert, wenn das Ganze in ein Makro 'ausgelagert' wird. Da dann durch die Makro-Pin's, evtl. zusätzliche Verzögerungen anfallen. Dasselbe kann auch, in einer grösseren Schaltung, der Fall sein (es ist zeitkritisch!).

Der Trigger ist einfach eine Ein-Komponenten-Lösung, welche warscheinlich weniger Rechen-Leistung benötigt.
Thommi77 hat geschrieben:Ein Problem können allerdings alle Vorschläge nicht lösen. Befindet sich keine *.est Datei ...
Na ja, so ein bisschen Verantwortung, muss jeder Programmierer, schon selber übernehmen ...
++++++
Gruss/regards IKT

Antworten

Zurück zu „Thema: Frontplatte und Frontplattenelemente“