abacom-online.de

Das offizielle Elektronik-Software Forum
Aktuelle Zeit: Sonntag 24. September 2017, 18:44

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 7 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Direkte Portzugriffe
BeitragVerfasst: Mittwoch 7. März 2012, 21:50 
Offline

Registriert: Mittwoch 14. April 2010, 17:53
Beiträge: 10
Wohnort: Berlin
Hallo Team, Hallo Gemeinde,

ich habe bei mir festgestellt, dass bei der Version vom 12.7.11 der LPT Zugriff, die allgemeinen Portzugriffe und LCD-Ansteuerung am LPT noch einwandfrei funktioniert.
Mit dem nächsten mir zur Verfügung stehendem Update vom 23.11.11 gehen o.g. Funktionen nicht mehr. Dazwischenliegende Updates hab ich leider nicht zur Verfügung. Auch mit dem letzten vom 23.2.12 geht's nicht.

Ich konnte es auf die Schnelle nur auf einem Rechner mit WinME checken.

Der Test ist relativ einfach: LCD in die Schaltung ziehen, Adresse auswählen (auch bei mir ist es 0378) und starten.
Es kommt die Fehlermeldung: Port Access failed. Die kann man wegklicken und die Simulation läuft weiter aber am Ausgang tut sich nichts.
Das geht auch mit dem Beispiel Relaisansteuerung sowie direkt E/A-Port write und sogar Port read.

Ich hab das mit den Updates verschiedene male ausprobiert und die Zielhardware möchte ich ausschließen, es sind nur ein paar LEDs direkt am LPT dran.
Besonders, dass die direkten Portzugriffe nicht mehr gehen ist schmerzlich. Die nehme ich um auch 8255er-Karten anzusteuern (weil der 8255 Baustein aus der Bilbliothek seit einiger Zeit nicht richtig funktioniert)

Geht es nur mir so?
Ich probier das auch gerne morgen mal auf einem XP-Rechner.


Dateianhänge:
Dateikommentar: Fehlermeldung bei Portzugriff oder LPT
PAF-Error.jpg
PAF-Error.jpg [ 10.13 KiB | 5139-mal betrachtet ]

_________________
Alles wird gut...
Zampano
Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Seit Update 23.11.11 LPT geht nicht mehr
BeitragVerfasst: Donnerstag 8. März 2012, 11:25 
Offline
Site Admin

Registriert: Dienstag 23. September 2008, 10:54
Beiträge: 3150
Versuchen Sie einmal diesen Portöffner zu installieren...
http://www.entechtaiwan.com/dev/port/index.shtm

_________________
ABACOM support


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Seit Update 23.11.11 LPT geht nicht mehr
BeitragVerfasst: Donnerstag 8. März 2012, 21:55 
Offline

Registriert: Mittwoch 14. April 2010, 17:53
Beiträge: 10
Wohnort: Berlin
Hallo Team,

ich bin beindruckt. Nach Installation von dem Progamm läufts auch wieder unter WinME.
(Da würde mich mal interessieren, wie das und was da gemacht wurde bzw. wie das funktioniert.)

Man braucht nur den Treiber mitzunehmen, die Beispiele für C/C++, VB etc. braucht man nicht.

Ich habe auch euer neuestes Update bez. Ports, LCD und Relaiskarten auf einem XP Rechner gecheckt, da lief es ohne Schwierrigkeiten.

Das Progrämmchen ist bestimmt auch für die Programmierer im Forum interessant, da Hardwarezugriffe aus den verschiedenen Programmirsprachen (auch VB, C#) möglich sind.
Mehr noch: Man kommt laut Hersteller an Memory-Mapped I/O ran! Das ist schon etwas besonderes, finde ich.

Danke nochmal,

_________________
Alles wird gut...
Zampano


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Seit Update 23.11.11 LPT geht nicht mehr
BeitragVerfasst: Mittwoch 1. Mai 2013, 19:04 
Offline

Registriert: Dienstag 24. November 2009, 11:38
Beiträge: 18
Hallo,

Ich habe auch das Problem, dass ich nur noch auf den ersten LPT Port schreiben kann. Eskommt zwar keine Fehlermeldung aber es passiert auch nichts.

Die LPT Ports sind via MOS Chips angebunden.

Ich habe die genannte Software auch installiert. Muss man hier noch was zusätzlich aktivieren ?


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Seit Update 23.11.11 LPT geht nicht mehr
BeitragVerfasst: Donnerstag 2. Mai 2013, 07:52 
Offline
Site Admin

Registriert: Dienstag 23. September 2008, 10:54
Beiträge: 3150
Nein, Portöffner und neuestes PL-Update sollten reichen. Admin-Rechte sind möglicherweise erforderlich.
Das Ganze ist aber natürlich nicht mehr zeitgemäss. Die Zeit der Portzugriffe ohne Treiber ist längst vorbei.
Und LPT ist ebenfalls tot, auch wenn´s traurig stimmen mag. :(

_________________
ABACOM support


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Seit Update 23.11.11 LPT geht nicht mehr
BeitragVerfasst: Donnerstag 2. Mai 2013, 08:21 
Offline

Registriert: Mittwoch 14. April 2010, 17:53
Beiträge: 10
Wohnort: Berlin
Hallo Mainframe,

ich brauchte bei mir eigentlich nichts weiter einstellen. Nach der Installation des Portopeners lief das anstandslos.

Der Portopener brauchst du aber wirklich nur unter 98/Me. Bei XP brauchst du den nicht, dafür Admin-Rechte.
Läuft denn deine Simulation los und lief sie irgendwann vorher schon mal? Erkennbar an der Frequenzanzeige oben rechts oder wenn du die Bauteilzustandsanzeige einschaltest.

Ich hab auch viele meiner LPTs über Multi-IO-Karten angeschlossen. Meist von Reichelt, auch mit MosChip-Chipsätzen.
Beim Einsatz von Multi-IO-Karten ist dann als LPT-Eigenschaft die erste Adresse des jeweiligen Ports anzugeben.
Die entnimmst du dem Gerätemanager/Anschlüsse(COM und LPT)/[LPT_xx/Ressourcen. Wobei der LPT_xx dein neuer LPT von der Multi-IO-Karte ist.
(Setzt natürlich voraus, dass die ordentlich installiert ist). Keine Ausrufezeichen im Geräte-Manager?
Die Adressen haben dann eigentlich immer ganz andere Einträge als die bekannten 0378 oder 0278.
Bei mir kommen solche Adressen vor: D000, B400 und andere.

Soweit meine ersten Ideen. Vielleicht ist ja der eine oder andere hilfreiche Hinweis dabei. Ansonsten bräuchte ich mehr Infos.

Ach ja: ich schließe mich der abacom-Meinung nicht an, dass LPTs tot sind. Solange noch Einsteckkarten (auch PCIe) gebaut werden und selbst für 64-Bit-Systeme Treiber erstellt werden sehe ich das nicht so. Das aber nur am Rande...

_________________
Alles wird gut...
Zampano


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Seit Update 23.11.11 LPT geht nicht mehr
BeitragVerfasst: Donnerstag 2. Mai 2013, 19:42 
Offline

Registriert: Dienstag 14. Oktober 2008, 17:06
Beiträge: 657
Wohnort: Markt Schwaben
Hallo Zampano.
Zampano hat geschrieben:
Ach ja: ich schließe mich der abacom-Meinung nicht an, dass LPTs tot sind. Solange noch Einsteckkarten (auch PCIe) gebaut werden und selbst für 64-Bit-Systeme Treiber erstellt werden sehe ich das nicht so. Das aber nur am Rande...

Ich sehe dies genauso.
Mir ist unerklärlich, warum der Paralleport immer wieder verteufelt wird.
Dies ist die am einfachsten zu handhabende Schnittstelle, die ich kenne.

############################################################################

Warum muss man auf Teufelkommraus einen Rechner/Laptop für PLE einsetzen, welcher außer USB nix hat?
Zumal es sehr günstig solche gibt, die noch klassische Schnittstellen aufweisen.
Hauptsache XP ist drauf. Alles andere ist nicht so wichtig.
Ich nutze seit vielen Jahren ausschließlich Laptops.
Wenn mal einer keinen PP hat, so gibt es ganz, ganz, ganz viele PCM CIA - Adapter.
Auch mit 2 Paralleports (siehe unteres Bild). Funktion in allen Fällen einwandfrei.

Wem diese Alternative immer noch nicht gefallen tut, der kann mit dem Abacom-Hardware-Modul CH341A den
Paralleport sehr leicht nachbilden. Und preisgünstig ist das Ding auch noch.
17 Steuerleitungen, davon 15 wahlweise als IN oder OUT nutzbar.
Und das gleichzeitig. Ist halt ein Parallel-Port........... ;)
Benötigt wird eine USB-Buchse, 1 Kondensator und ein Widerstand. Der Rest ist Draht.
Ganz nebenbei bekommt man zusätzlich eine I2C-Masterschnittstelle spendiert.
Alles leicht konfigurierbar. Siehe PLE-Beispiele (Hardware/ LPT und I2C).

Anbei eine Basisschaltung. Und ein Foto der Hardware.
Mit einer winzigen Erweiterung kann man alle IN und OUT´s einfach auf Funktion testen.
Dazu nimmt man am einfachsten aus den Beispielen: Hardware/ Abacom/ CH341A/ set_output.prj

Gruß von C :shock: mpander.


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 7 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Deutsche Übersetzung durch phpBB.de