Die Suche ergab 6 Treffer

von alex_evil
Mittwoch 27. Mai 2020, 18:05
Forum: Thema Modbus
Thema: Neuer Modbus Client - Paketlänge und Stabilität
Antworten: 15
Zugriffe: 1350

Re: Neuer Modbus Client - Paketlänge und Stabilität

The same problem for me too. I solved it temporarily by dividing the application into two different applications. Compiling the modbus server with the 2019 version and exchanging data with the application compiled with the 2020 version with DDE. I created a laucher that starts the modbus server appl...
von alex_evil
Freitag 8. März 2019, 23:29
Forum: Thema Modbus
Thema: New Modbus Client Very Slow
Antworten: 2
Zugriffe: 1633

Re: New Modbus Client Very Slow

New modbus client is working realy slow even for me. I've made every test. I found out that the old modbus client keeps the TCP socket always open, the new modbus client closes the socket after each message and then opens it again for each new message. it would be great if a checkbox like "keep the ...
von alex_evil
Sonntag 3. Juni 2012, 13:07
Forum: Thema Modbus
Thema: Strange CPU Usage with fast run mode
Antworten: 8
Zugriffe: 6022

Re: Strange CPU Usage with fast run mode

Hi, I tried it with low speed and the problem remains the same. The application freezing regularly only when modbus devices are disconnected or the network is not avaible. For me is not a big issue but i think the problem is in the modbus error handling. I have Profilab Expert with the last update (...
von alex_evil
Mittwoch 23. Mai 2012, 15:45
Forum: Thema Modbus
Thema: Strange CPU Usage with fast run mode
Antworten: 8
Zugriffe: 6022

Re: Strange CPU Usage with fast run mode

Hi,
other processes does not block ProfiLab.
if I make a test application without modbus tcp reading holding registers everything works properly.

Alessandro
von alex_evil
Mittwoch 23. Mai 2012, 12:11
Forum: Thema Modbus
Thema: Strange CPU Usage with fast run mode
Antworten: 8
Zugriffe: 6022

Re: Strange CPU Usage with fast run mode

How can I check this?

Thank's
Alessandro
von alex_evil
Montag 21. Mai 2012, 10:16
Forum: Thema Modbus
Thema: Strange CPU Usage with fast run mode
Antworten: 8
Zugriffe: 6022

Strange CPU Usage with fast run mode

Hi Abacom, i have a little problem with my application. When I use it with fast run mode at regular intervals of time the application freezing for a short period. As attachment you can see the screenshot of the use of the processor from the task manager. I try to run the application into Windows XP ...

Zur erweiterten Suche