Analogwert einer Wago Klemme abfragen

Antworten
twofel
Beiträge: 27
Registriert: Samstag 2. März 2013, 20:38

Analogwert einer Wago Klemme abfragen

Beitrag von twofel » Dienstag 5. März 2013, 13:24

Hallo,

ich habe auf einem Wago 750-841 Starterkit eine Wagoklemme ( 750-478 ) -also eine Analogklemme ( Bereich: 0-10Volt DC )
stecken.
Ich messe eine Spannung in dem Bereich von 0 - 10 Volt an dem ersten Eingang der Klemme.

In Profilab habe ich dazu ein Projekt erstellt:

Bild

Wenn ich die Simulation starte, zeigt mir das Meßinstrument auf dem Frontpanel die richtige Spannung an.
Eine Korrekturtabelle habe ich extra angelegt, da laut Datenblatt der Analogklemme 750-478 eine MAximalspannung
von 10 Volt einem Dezimalwert von 32767 entspricht.

Wenn ich mir die Simulation betrachte, sehe ich, daß der REG2 Ausgang ebenfalls aktiv ist. Warum ?
Ich dachte REG1 entspricht einem 16 bit Register , also dem 1. Kanal der Klemme . Oder sehe ich das falsch ?
MfG Tim

breitech
Beiträge: 19
Registriert: Mittwoch 20. April 2011, 13:10

Re: Analogwert einer Wago Klemme abfragen

Beitrag von breitech » Dienstag 5. März 2013, 16:51

Hallo Twofel

die 750-478 ist ein 2 Kanal Analog-In
da ev nicht beschaltet kann sein das du hier irgend eine Spannung hast
entweder 2.Kanal auf 0 legen
oder das Input-Register mit nur 1 Kanal betreiben

Gruß

Christian

twofel
Beiträge: 27
Registriert: Samstag 2. März 2013, 20:38

Re: Analogwert einer Wago Klemme abfragen

Beitrag von twofel » Dienstag 5. März 2013, 17:09

breitech hat geschrieben:Hallo Twofel

die 750-478 ist ein 2 Kanal Analog-In
da ev nicht beschaltet kann sein das du hier irgend eine Spannung hast
entweder 2.Kanal auf 0 legen
oder das Input-Register mit nur 1 Kanal betreiben

Gruß

Christian

Ich weiss , dass es eine 2 KAnal Analog Klemme ist.
Habe den 2. Eingang mal auf Masse gelegt. Ist trotzdem aktiv. Keine Änderung.
MfG Tim

hrathke
Beiträge: 157
Registriert: Montag 12. Dezember 2011, 21:10

Re: Analogwert einer Wago Klemme abfragen

Beitrag von hrathke » Dienstag 5. März 2013, 18:47

Hallo,

da Du die (zweite) Adresse ansprichst - ist diese auch aktiv - auch 0 ist ein Wert :D

Gruß
HR

twofel
Beiträge: 27
Registriert: Samstag 2. März 2013, 20:38

Re: Analogwert einer Wago Klemme abfragen

Beitrag von twofel » Dienstag 5. März 2013, 19:11

ok...dann ist ja alles i.O.
MfG Tim

abacom
Site Admin
Beiträge: 3458
Registriert: Dienstag 23. September 2008, 10:54
Kontaktdaten:

Re: Analogwert einer Wago Klemme abfragen

Beitrag von abacom » Donnerstag 7. März 2013, 08:55

Vielleicht sollte einmal gesagt werden auf WELCHE Register überhaupt zu gegriffen wird.
Die müssten in der Doku stehen (die ich aber nicht auf Anhieb verstehe).
http://www.wago.com/wagoweb/documentati ... 00_0de.pdf
ABACOM support

abacom
Site Admin
Beiträge: 3458
Registriert: Dienstag 23. September 2008, 10:54
Kontaktdaten:

Re: Analogwert einer Wago Klemme abfragen

Beitrag von abacom » Donnerstag 7. März 2013, 09:06

Vielleicht kann Ihnen der Beitrag von "DMULTI" weiterhelfen...
viewtopic.php?f=21&t=3013&hilit=Wago
( Tolle Sache diese Suchfunktion ;-) )
ABACOM support

twofel
Beiträge: 27
Registriert: Samstag 2. März 2013, 20:38

Re: Analogwert einer Wago Klemme abfragen

Beitrag von twofel » Donnerstag 7. März 2013, 17:08

abacom hat geschrieben:Vielleicht sollte einmal gesagt werden auf WELCHE Register überhaupt zu gegriffen wird.
Die müssten in der Doku stehen (die ich aber nicht auf Anhieb verstehe).
Zugegeben...bei der Doku hatte ich auch meine Schwierigkeiten. Hier wird ja nur auf Seite 230 gesagt
wie sich der Modbus Befehl FC 4 zusammensetzt. Im Responce ist mal ein Hinweis, daß im Byte 9 und 10
der Wert des Registers 0 und im Byte 11 und 12 der Wert des Registers 11 steht.

Siehe hier.

Bild

Und in der Doku der Busklemme ( 2 AI DC 0-10 V, Single-Ended 750-478) steht ein Hinweis
zum Wertebereich der beiden Eingänge.

Siehe hier

Bild

Insofern bin ich davon ausgegangen, dass ich hier zwei 16-bit Register abfrage und demzufolge den
Baustein "Read Input Registers" verwenden muß.
MfG Tim

twofel
Beiträge: 27
Registriert: Samstag 2. März 2013, 20:38

Re: Analogwert einer Wago Klemme abfragen

Beitrag von twofel » Donnerstag 7. März 2013, 17:55

Habe meine Schaltung ein wenig erweitert und zu Testzwecken an den 1. Kanal
der Analogklemme ein 9 Volt Block und an den 2. Kanal der Analogklemme einen
1,5 Volt Akku gehängt. Auf beiden Kanälen wird die richtige Spannung gemessen.

Bild
MfG Tim

twofel
Beiträge: 27
Registriert: Samstag 2. März 2013, 20:38

Re: Analogwert einer Wago Klemme abfragen

Beitrag von twofel » Donnerstag 7. März 2013, 20:52

WoB hat geschrieben:Generator NICHT parallel auf alle CLK's zu legen.
Besser z.B. nur auf den ersten "CLK" links, von da aus mit BSY auf den nächsten CLK usw. so dass sich eine Kette bildet.
M.f.G. WoB
Ok...Danke fuer den Hinweis !

So ist's dann besser:

Bild
MfG Tim

Antworten

Zurück zu „Thema Modbus“