com String empfangen mit null als Trennzeichen

Antworten
Stefan
Beiträge: 11
Registriert: Montag 10. November 2008, 21:28

com String empfangen mit null als Trennzeichen

Beitrag von Stefan » Donnerstag 29. Juli 2010, 09:59

Hallo,
ich möchte einen Wechselrichter per RS232 auslesen, mein Problem ist das dieser als Trennzeichen nur eine Null in Hex sendet und die Null wird vom com String empfangen Bauteil nicht erkannt.
Hat jemand eine Idee für mein Problem ?

MfG
Stefan

KAKTUS
Beiträge: 645
Registriert: Samstag 18. Oktober 2008, 21:12

Re: com String empfangen mit null als Trennzeichen

Beitrag von KAKTUS » Donnerstag 29. Juli 2010, 11:47

siehe
viewtopic.php?f=26&t=1659

Das Problem hatte ich auch schon
stachlige Grüße, Kaktus

tmm
Beiträge: 365
Registriert: Montag 23. Februar 2009, 06:38

Re: com String empfangen mit null als Trennzeichen

Beitrag von tmm » Freitag 30. Juli 2010, 14:01

Hallo,

in dem angehängten Projekt kann man Strings einlesen (mühsam), die mit einer "0" als Trennzeichen gesendet werden.
Um das Zerlegen des eingelesenen Strings müsst ihr euch selbst kümmern :roll:

Einfacher wäre es jedefalls, wenn die "0" als Trennzeichen erkannt werden würde.

Gruß MM
Dateianhänge
com_test.prj
(3.87 KiB) 270-mal heruntergeladen

Stefan
Beiträge: 11
Registriert: Montag 10. November 2008, 21:28

Re: com String empfangen mit null als Trennzeichen

Beitrag von Stefan » Donnerstag 5. August 2010, 17:37

Danke MM !
damit gehts jetzt

Gruß
stefan

KAKTUS
Beiträge: 645
Registriert: Samstag 18. Oktober 2008, 21:12

Re: com String empfangen mit null als Trennzeichen

Beitrag von KAKTUS » Mittwoch 11. August 2010, 21:03

@Abacom

Wollte nur nochmal auf das Problem aufmerksam machen, falls es übersehen wurde.
stachlige Grüße, Kaktus

Antworten

Zurück zu „Thema RS232“