Problem on rs-232, help

KAKTUS
Beiträge: 645
Registriert: Samstag 18. Oktober 2008, 21:12

Re: Problem on rs-232, help

Beitrag von KAKTUS » Montag 19. April 2010, 20:54

Question 1:
Did you run your project in FAST or SLOW Mode? You should try FAST


Question 2:
Try higher baud rate like 115200 better?

Qustion 3.
Please report more about your PC, operating system, CPU, did you use RS232 -> USB adapter ?

Please try new Project. It records now the hole output from $CR1
Please send back MWR.TXT

You can try again to add a pause DelayMS 100 or more , maybe its a buffer overflow ?
Dateianhänge
kaktus_serial_test_new.prj
(3.51 KiB) 193-mal heruntergeladen
stachlige Grüße, Kaktus

Maxiq4
Beiträge: 24
Registriert: Sonntag 2. November 2008, 17:23

Re: Problem on rs-232, help

Beitrag von Maxiq4 » Mittwoch 21. April 2010, 08:25

KAKTUS hat geschrieben:Question 1:
Did you run your project in FAST or SLOW Mode? You should try FAST


Question 2:
Try higher baud rate like 115200 better?

Qustion 3.
Please report more about your PC, operating system, CPU, did you use RS232 -> USB adapter ?

Please try new Project. It records now the hole output from $CR1
Please send back MWR.TXT

You can try again to add a pause DelayMS 100 or more , maybe its a buffer overflow ?
hi kaktus ,

your first questions answer is in my last topic ,
yes Im trying slow and fast setting ,
Im use fast ,
and Im send a data file ,
include,
4800 baudrate fast and slow
19200 baudrate fast and slow
34800 baudrate fast and slow txt outs .
Im normally use fast always.

Question 2:
Im try 34800 and give me quickly error ,
I dont try 115200 , Im sure its worse than 34800.
Im remember before, I did test it 115200, its worse.

Qustion 3.
notebook is hp pavillion dv500 model ,
it has 3gb ram, xp sp3
intel core duo T2300, 1.6 ghz cpu
its working good.

usb to serial adaptor is classic prolific adaptor .
It must be PL2303 chip .
I said before, Im test it other pc and pcmcia usb to serial adaptor also .


and here new data log files
include delayms 100

regards
Dateianhänge
Data2.rar
(22.96 KiB) 192-mal heruntergeladen

Maxiq4
Beiträge: 24
Registriert: Sonntag 2. November 2008, 17:23

Re: Problem on rs-232, help

Beitrag von Maxiq4 » Mittwoch 21. April 2010, 09:18

Kaktus,

can we add a analog buffer between rsport and part ?

here:
Dateianhänge
pic1.JPG
pic1.JPG (12.15 KiB) 2715 mal betrachtet

KAKTUS
Beiträge: 645
Registriert: Samstag 18. Oktober 2008, 21:12

Re: Problem on rs-232, help

Beitrag von KAKTUS » Freitag 23. April 2010, 13:55

Sorry, but at the moment i am at the and of my knowledge.
stachlige Grüße, Kaktus

Maxiq4
Beiträge: 24
Registriert: Sonntag 2. November 2008, 17:23

Re: Problem on rs-232, help

Beitrag von Maxiq4 » Montag 26. April 2010, 12:46

KAKTUS ,
really thanks your help and effort .

Antworten

Zurück zu „Thema RS232“